#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)[0-9]+\s?[–|-]?\s?[0-9]*\s?g{0,1}\b"
Local $sString = "100g Butter" & @CRLF & _
"100-300g Butter" & @CRLF & _
"100 - 300g Butter"
Local $sSubst = "1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)