const regex = /[0-9]+\s?[–|-]?\s?[0-9]*\s?g{0,1}\b/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[0-9]+\\s?[–|-]?\\s?[0-9]*\\s?g{0,1}\\b', 'gi')
const str = `100g Butter
100-300g Butter
100 - 300g Butter`;
const subst = `1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);