using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[0-9]+\s?[–|-]?\s?[0-9]*\s?g{0,1}\b";
string substitution = @"1";
string input = @"100g Butter
100-300g Butter
100 - 300g Butter";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}