// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)[0-9]+\s?[–|-]?\s?[0-9]*\s?g{0,1}\b").unwrap();
let string = "100g Butter
100-300g Butter
100 - 300g Butter";
let substitution = "1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}