package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)[0-9]+\s?[–|-]?\s?[0-9]*\s?g{0,1}\b`)
var str = `100g Butter
100-300g Butter
100 - 300g Butter`
var substitution = "1"
fmt.Println(re.ReplaceAllString(str, substitution))
}