use strict;
my $str = '100g Butter
100-300g Butter
100 - 300g Butter';
my $regex = qr/[0-9]+\s?[–|-]?\s?[0-9]*\s?g{0,1}\b/ip;
my $subst = '1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";