import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[0-9]+\\s?[–|-]?\\s?[0-9]*\\s?g{0,1}\\b";
final String string = "100g Butter\n"
+ "100-300g Butter\n"
+ "100 - 300g Butter";
final String subst = "1";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}