re = /[0-9]+\s?[–|-]?\s?[0-9]*\s?g{0,1}\b/i
str = '100g Butter
100-300g Butter
100 - 300g Butter'
subst = '1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result