# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[a-zA-z]//md;t' <<< "123;
qwer12324,
874374873,
yGYGFS7676868,
Hallo,
qwert,
a,
"