use strict;
my $str = '123;
qwer12324,
874374873,
yGYGFS7676868,
Hallo,
qwert,
a,
';
my $regex = qr/^[a-zA-z]/mdp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";