#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?md)^[a-zA-z]"
Local $sString = "123;" & @CRLF & _
"qwer12324," & @CRLF & _
"874374873, " & @CRLF & _
"yGYGFS7676868," & @CRLF & _
"" & @CRLF & _
"Hallo," & @CRLF & _
"qwert," & @CRLF & _
"a," & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)