const regex = /^[a-zA-z]/md;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zA-z]', 'md')
const str = `123;
qwer12324,
874374873,
yGYGFS7676868,
Hallo,
qwert,
a,
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);