#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^((?:[^,\r\n]*,){X})[^,\r\n]*,((?:[^,\r\n]*,){Y})[^,\r\n]*(.*)"
Local $sString = "a,{X}b,c,{Y}d" & @CRLF & _
"aaa,{X}2.15,100.15,{Y}-" & @CRLF & _
"bbb,{X}3.16,215.16,{Y}-" & @CRLF & _
"ccc,{X}4.10,365.18,{Y}-"
Local $sSubst = "$1$2$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)