import Foundation
let pattern = #"(?m)^((?:[^,\r\n]*,){X})[^,\r\n]*,((?:[^,\r\n]*,){Y})[^,\r\n]*(.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
a,{X}b,c,{Y}d
aaa,{X}2.15,100.15,{Y}-
bbb,{X}3.16,215.16,{Y}-
ccc,{X}4.10,365.18,{Y}-
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)