import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)^((?:[^,\\r\\n]*,)\\{X\\})[^,\\r\\n]*,((?:[^,\\r\\n]*,)\\{Y\\})[^,\\r\\n]*(.*)";
final String string = "a,{X}b,c,{Y}d\n"
+ "aaa,{X}2.15,100.15,{Y}-\n"
+ "bbb,{X}3.16,215.16,{Y}-\n"
+ "ccc,{X}4.10,365.18,{Y}-";
final String subst = "$1$2$3";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}