const regex = /(?m)^((?:[^,\r\n]*,){X})[^,\r\n]*,((?:[^,\r\n]*,){Y})[^,\r\n]*(.*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?m)^((?:[^,\\r\\n]*,){X})[^,\\r\\n]*,((?:[^,\\r\\n]*,){Y})[^,\\r\\n]*(.*)', 'g')
const str = `a,{X}b,c,{Y}d
aaa,{X}2.15,100.15,{Y}-
bbb,{X}3.16,215.16,{Y}-
ccc,{X}4.10,365.18,{Y}-`;
const subst = `$1$2$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);