$re = '/(?m)^((?:[^,\r\n]*,){X})[^,\r\n]*,((?:[^,\r\n]*,){Y})[^,\r\n]*(.*)/';
$str = 'a,{X}b,c,{Y}d
aaa,{X}2.15,100.15,{Y}-
bbb,{X}3.16,215.16,{Y}-
ccc,{X}4.10,365.18,{Y}-';
$subst = "$1$2$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;