package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((?:[^,\r\n]*,){X})[^,\r\n]*,((?:[^,\r\n]*,){Y})[^,\r\n]*(.*)`)
var str = `a,{X}b,c,{Y}d
aaa,{X}2.15,100.15,{Y}-
bbb,{X}3.16,215.16,{Y}-
ccc,{X}4.10,365.18,{Y}-`
var substitution = "$1$2$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}