using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)^((?:[^,\r\n]*,){X})[^,\r\n]*,((?:[^,\r\n]*,){Y})[^,\r\n]*(.*)";
string substitution = @"$1$2$3";
string input = @"a,{X}b,c,{Y}d
aaa,{X}2.15,100.15,{Y}-
bbb,{X}3.16,215.16,{Y}-
ccc,{X}4.10,365.18,{Y}-";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}