// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((?:[^,\r\n]*,){X})[^,\r\n]*,((?:[^,\r\n]*,){Y})[^,\r\n]*(.*)").unwrap();
let string = "a,{X}b,c,{Y}d
aaa,{X}2.15,100.15,{Y}-
bbb,{X}3.16,215.16,{Y}-
ccc,{X}4.10,365.18,{Y}-";
let substitution = "$1$2$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}