#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\d+\.)\h+(\d+)"
Local $sString = "EB:3668. 19KWh DB:22. 29KWh" & @CRLF & _
"EB:3668.19KWh DB:22.29KWh"
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)