re = /(\d+\.)\h+(\d+)/m
str = 'EB:3668. 19KWh DB:22. 29KWh
EB:3668.19KWh DB:22.29KWh'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result