package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+\.)\h+(\d+)`)
var str = `EB:3668. 19KWh DB:22. 29KWh
EB:3668.19KWh DB:22.29KWh`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}