const regex = new RegExp('(\\d+\\.)\\h+(\\d+)', 'gm')
const str = `EB:3668. 19KWh DB:22. 29KWh
EB:3668.19KWh DB:22.29KWh`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);