import re
regex = re.compile(r"(\d+\.)\h+(\d+)", flags=re.MULTILINE)
test_str = ("EB:3668. 19KWh DB:22. 29KWh\n"
"EB:3668.19KWh DB:22.29KWh")
subst = "$1$2"
result = regex.sub(subst, test_str)
if result:
print(result)