using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+\.)\h+(\d+)";
string substitution = @"$1$2";
string input = @"EB:3668. 19KWh DB:22. 29KWh
EB:3668.19KWh DB:22.29KWh";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}