use strict;
my $str = 'EB:3668. 19KWh DB:22. 29KWh
EB:3668.19KWh DB:22.29KWh';
my $regex = qr`(\d+\.)\h+(\d+)`mp;
my $subst = '$1$2';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";