import Foundation
let pattern = #"(\d+\.)\h+(\d+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
EB:3668. 19KWh DB:22. 29KWh
EB:3668.19KWh DB:22.29KWh
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)