// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d+\.)\h+(\d+)").unwrap();
let string = "EB:3668. 19KWh DB:22. 29KWh
EB:3668.19KWh DB:22.29KWh";
let substitution = "$1$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}