import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*\\)\\s*(.*)\\s*\\([mf]\\).*";
final String string = "Dr. T. (Tom) Bailey (m), UCL- Physics\n"
+ "Dr. B.K. (Barbara) Blue (f), Oxford - Political Science";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}