re = /.*\)\s*(.*)\s*\([mf]\).*/
str = 'Dr. T. (Tom) Bailey (m), UCL- Physics
Dr. B.K. (Barbara) Blue (f), Oxford - Political Science'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result