use strict;
my $str = 'Dr. T. (Tom) Bailey (m), UCL- Physics
Dr. B.K. (Barbara) Blue (f), Oxford - Political Science';
my $regex = qr/.*\)\s*(.*)\s*\([mf]\).*/p;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";