// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".*\)\s*(.*)\s*\([mf]\).*").unwrap();
let string = "Dr. T. (Tom) Bailey (m), UCL- Physics
Dr. B.K. (Barbara) Blue (f), Oxford - Political Science";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}