import Foundation
let pattern = #".*\)\s*(.*)\s*\([mf]\).*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Dr. T. (Tom) Bailey (m), UCL- Physics
Dr. B.K. (Barbara) Blue (f), Oxford - Political Science
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)