const regex = /.*\)\s*(.*)\s*\([mf]\).*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*\\)\\s*(.*)\\s*\\([mf]\\).*', 'g')
const str = `Dr. T. (Tom) Bailey (m), UCL- Physics
Dr. B.K. (Barbara) Blue (f), Oxford - Political Science`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);