import re
regex = re.compile(r".*\)\s*(.*)\s*\([mf]\).*")
test_str = ("Dr. T. (Tom) Bailey (m), UCL- Physics\n"
"Dr. B.K. (Barbara) Blue (f), Oxford - Political Science")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)