# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/href=".+?id=(.+?)"/href="\/lookup?id=$1"/;t' <<< "<a href=\"#SCRIPT_NAME#?a=b&id=a/b/c/d\">Link Content</a>"