$re = '/href=".+?id=(.+?)"/';
$str = '<a href="#SCRIPT_NAME#?a=b&id=a/b/c/d">Link Content</a>';
$subst = "href=\"/lookup?id=$1\"";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;