re = /href=".+?id=(.+?)"/
str = '<a href="#SCRIPT_NAME#?a=b&id=a/b/c/d">Link Content</a>'
subst = 'href="/lookup?id=$1"'
result = str.sub(re, subst)
# Print the result of the substitution
puts result