use strict;
my $str = '<a href="#SCRIPT_NAME#?a=b&id=a/b/c/d">Link Content</a>';
my $regex = qr/href=".+?id=(.+?)"/p;
my $subst = 'href="/lookup?id=$1"';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";