using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"href="".+?id=(.+?)""";
string substitution = @"href=""/lookup?id=$1""";
string input = @"<a href=""#SCRIPT_NAME#?a=b&id=a/b/c/d"">Link Content</a>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}