// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"href=".+?id=(.+?)""#).unwrap();
let string = "<a href=\"#SCRIPT_NAME#?a=b&id=a/b/c/d\">Link Content</a>";
let substitution = "href=\"/lookup?id=$1\"";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}