import re
regex = re.compile(r"href=\".+?id=(.+?)\"")
test_str = "<a href=\"#SCRIPT_NAME#?a=b&id=a/b/c/d\">Link Content</a>"
subst = "href=\"/lookup?id=$1\""
result = regex.sub(subst, test_str, count=1)
if result:
print(result)