const regex = /href=".+?id=(.+?)"/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('href=".+?id=(.+?)"', '')
const str = `<a href="#SCRIPT_NAME#?a=b&id=a/b/c/d">Link Content</a>`;
const subst = `href="/lookup?id=$1"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);