import Foundation
let pattern = #"href=".+?id=(.+?)""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"<a href="#SCRIPT_NAME#?a=b&id=a/b/c/d">Link Content</a>"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"href="/lookup?id=$1""#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}