#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\/?[^\/]*(\/(.*))?$"
Local $sString = "/qualquer-coisa/index.php" & @CRLF & _
"/qualquer-coisa1/index.php" & @CRLF & _
"/qualquer-coisa2/index.php" & @CRLF & _
"/qualquer-coisa3/index.php" & @CRLF & _
"/qualquer-coisa4/index.php" & @CRLF & _
"/qualquer-coisa5/index.php" & @CRLF & _
"/qualquer-coisa6/" & @CRLF & _
"/qualquer-coisa7"
Local $sSubst = "/pasta_do_site/$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)