import re
regex = re.compile(r"^\/?[^\/]*(\/(.*))?$", flags=re.MULTILINE)
test_str = ("/qualquer-coisa/index.php\n"
"/qualquer-coisa1/index.php\n"
"/qualquer-coisa2/index.php\n"
"/qualquer-coisa3/index.php\n"
"/qualquer-coisa4/index.php\n"
"/qualquer-coisa5/index.php\n"
"/qualquer-coisa6/\n"
"/qualquer-coisa7")
subst = "/pasta_do_site/$2"
result = regex.sub(subst, test_str)
if result:
print(result)