const regex = /^\/?[^\/]*(\/(.*))?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\\/?[^\\\/]*(\\\/(.*))?$', 'gm')
const str = `/qualquer-coisa/index.php
/qualquer-coisa1/index.php
/qualquer-coisa2/index.php
/qualquer-coisa3/index.php
/qualquer-coisa4/index.php
/qualquer-coisa5/index.php
/qualquer-coisa6/
/qualquer-coisa7`;
const subst = `/pasta_do_site/$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);