import Foundation
let pattern = #"^\/?[^\/]*(\/(.*))?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/qualquer-coisa/index.php
/qualquer-coisa1/index.php
/qualquer-coisa2/index.php
/qualquer-coisa3/index.php
/qualquer-coisa4/index.php
/qualquer-coisa5/index.php
/qualquer-coisa6/
/qualquer-coisa7
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"/pasta_do_site/$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)