re = /^\/?[^\/]*(\/(.*))?$/m
str = '/qualquer-coisa/index.php
/qualquer-coisa1/index.php
/qualquer-coisa2/index.php
/qualquer-coisa3/index.php
/qualquer-coisa4/index.php
/qualquer-coisa5/index.php
/qualquer-coisa6/
/qualquer-coisa7'
subst = '/pasta_do_site/$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result